Welcome Guest ( Log In | Register )

 Forum Rules Extensions Support
 
Reply to this topicStart new topic
> Posts Fail To Assign Correct Category
Knerkin
post Jan 17 2013, 09:58 PM
Post #1


Newbie
*

Group: Members
Posts: 7
Joined: 7-January 13
Member No.: 1,507



I have set up 4 separate "users" by assigning unique filter e-mail addresses, designating unique categories for each, and using the same inbound e-mail address for all four. Each also has a unique author name.

When Post-by-E-Mail processes inbound messages, they fail to be assigned the designated category or author, receiving instead another category assigned to another user.

Need I use unique inbound e-mail addresses for each "user"?
Go to the top of the page
 
+Quote Post
Ivan Stamenov
post Jan 18 2013, 07:03 AM
Post #2


Advanced User
****

Group: Advanced Member
Posts: 218
Joined: 15-April 11
Member No.: 761



Hello, Knerkin.

In short, yes.

A few months ago we had a similar problem with another user. She had five different e-mail addresses, hosted by a single service provider. Each address has been assigned to a different PBE entry. When importing the PBE entries, the messages in all the e-mail boxes were imported in the first PBE entry's category.

The reason was, that though the e-mail boxes had different names, the mail server of the service provider returned all the messages (in all the boxes) when PBE was importing only the first one.

Best regards,

Ivan
Go to the top of the page
 
+Quote Post
Knerkin
post Jan 18 2013, 12:24 PM
Post #3


Newbie
*

Group: Members
Posts: 7
Joined: 7-January 13
Member No.: 1,507



It appears, then, that your filtering doesn't work, since it appears to be insensitive to the "include" From: content within each e-mail message.

How, then, can this extension ever work for more than one originator?

In the instance I reported about, there was only ONE message imported, and it ended up in the incorrect category, authored by the incorrect member.

It does NOT work as advertised.

In the case you cite, perhaps I don't understand fully what you're saying. You state that she had 5 different e-mail addresses, but your import fetched e-mail from all 5 when requesting the first. How can this be, since they are different e-mail accounts.

I'm sure we can work this out.

This post has been edited by Knerkin: Jan 18 2013, 01:01 PM
Go to the top of the page
 
+Quote Post
Ivan Stamenov
post Jan 21 2013, 07:05 AM
Post #4


Advanced User
****

Group: Advanced Member
Posts: 218
Joined: 15-April 11
Member No.: 761



Our component relies on the pop3 class to connect and retrieve the messages, associated (only) with the account details, provided by you in the PBE entry settings.

In the case I was talking about, using the account credentials for one of the e-mails, the pop3 class was given access to all the e-mail boxes and the messages within them. It has something to do with the e-mail server settings and nothing to do with our component.
Go to the top of the page
 
+Quote Post
Knerkin
post Jan 21 2013, 10:31 AM
Post #5


Newbie
*

Group: Members
Posts: 7
Joined: 7-January 13
Member No.: 1,507



Let's get back to a case I experienced. ONE e-mail was received. The sender was disallowed. However, the message ended up assigned a category and author. The following cron output was created by the SINGLE disallowed email.

adrian@xxxxxxx.com: This e-mail is not allowed to publish content (Sender Filter). The content is ignored.

1 emails were imported (Curt Akin) in 0 seconds.
1 emails were imported (James Herman) in 0 seconds.
0 emails were imported (Adrian Kuzminski ) in 0 seconds.
0 emails were imported (Robert Seward) in 0 seconds.
Go to the top of the page
 
+Quote Post
Ivan Stamenov
post Jan 21 2013, 10:51 AM
Post #6


Advanced User
****

Group: Advanced Member
Posts: 218
Joined: 15-April 11
Member No.: 761



The message should read "processed" instead of "imported" as this number is exactly the number of processed messages (not the imported ones).

Does the message gets actually imported? Is there an article created?

If yes, I will need admin & FTP access to your site in order to investigate what is happening.
Go to the top of the page
 
+Quote Post
Knerkin
post Jan 21 2013, 11:06 AM
Post #7


Newbie
*

Group: Members
Posts: 7
Joined: 7-January 13
Member No.: 1,507



OK, it should read "processed" but, note that TWO "processed" appear for one disallowed message. And, yes, the article was created.

Give me instructions as to where to send admin and FTP access info.
Go to the top of the page
 
+Quote Post
Knerkin
post Jan 21 2013, 02:53 PM
Post #8


Newbie
*

Group: Members
Posts: 7
Joined: 7-January 13
Member No.: 1,507



Here is an additional result from a single message:

adrian@xxxxxxx.com: This e-mail is not allowed to publish content (Sender Filter). The content is ignored.
adrian@xxxxxxx.com: This e-mail is not allowed to publish content (Sender Filter). The content is ignored.

1 emails were imported (Curt Akin) in 0 seconds.
1 emails were imported (James Herman) in 0 seconds.
1 emails were imported (Adrian Kuzminski ) in 0 seconds.
0 emails were imported (Robert Seward) in 0 seconds.

That e-mail address IS allowed. It ended up in the proper category by the correct author. The results of processing incoming messages seems unstable.
Go to the top of the page
 
+Quote Post
Knerkin
post Jan 21 2013, 05:17 PM
Post #9


Newbie
*

Group: Members
Posts: 7
Joined: 7-January 13
Member No.: 1,507



arakawarobert@xxxxxxxx.com: This e-mail is not allowed to publish content (Sender Filter). The content is ignored.
arakawarobert@xxxxxxxx.com: This e-mail is not allowed to publish content (Sender Filter). The content is ignored.
arakawarobert@xxxxxxxx.com: This e-mail is not allowed to publish content (Sender Filter). The content is ignored.

1 emails were imported (Curt Akin) in 0 seconds.
1 emails were imported (James Herman) in 0 seconds.
1 emails were imported (Adrian Kuzminski ) in 0 seconds.
1 emails were imported (Robert Seward) in 0 seconds.

The above was produced by cron's processing of the 4th person on the list of alloweds. It was given both the proper author and category.

It appears as if the extension correctly disallows in the first 3 persons, correctly processes it in the correct list, but incorrectly reports that the email was imported in the first 3.

This post has been edited by Knerkin: Jan 21 2013, 05:20 PM
Go to the top of the page
 
+Quote Post
Knerkin
post Jan 22 2013, 09:28 PM
Post #10


Newbie
*

Group: Members
Posts: 7
Joined: 7-January 13
Member No.: 1,507



Have you lost interest in this problem?

Most recent:

jamesherman@xxxxxxxx.com: This e-mail is not allowed to publish content (Sender Filter). The content is ignored.

1 emails were imported (Curt Akin) in 0 seconds.
1 emails were imported (James Herman) in 0 seconds.
0 emails were imported (Adrian Kuzminski ) in 0 seconds.
0 emails were imported (Robert Seward) in 0 seconds.

This e-mail WAS posted (contrary to the "ignored"). It was assigned the correct category but the incorrect author.

And, this cron output was produced by ONE e-mail.
Go to the top of the page
 
+Quote Post
Web Design Seo
post Jan 23 2013, 07:09 AM
Post #11


Web Design Seo
****

Group: Root Admin
Posts: 4,161
Joined: 29-April 09
From: Sofia
Member No.: 1



Цитат
Have you lost interest in this problem?

No, we have interest to help you and to make extension better. Please, say us: what you suggest to change in component?


--------------------
Правила на форума | Forum Rules | How to receive support. 3D Web Design: Уеб дизайн, Seo оптимизация, Web Site Extensions, Oscommerce Addons, Wordpress plugins and Joomla Extensions. Изработка на уеб сайтове и оптимизация на сайт за търсачки и Seo услуги.
Go to the top of the page
 
+Quote Post
kibangkok
post Feb 15 2013, 06:55 AM
Post #12


Newbie
*

Group: Members
Posts: 5
Joined: 20-July 12
From: thailand
Member No.: 1,281



QUOTE (Web Design Seo @ Jan 23 2013, 08:09 AM) *
No, we have interest to help you and to make extension better. Please, say us: what you suggest to change in component?


hi may you advise me.
after i install postbyemail, i try to set up the import email but i found problem about category. there is no category popup to choose. how should i do. thanks again for your advise.
Go to the top of the page
 
+Quote Post
Web Design Seo
post Feb 15 2013, 07:23 AM
Post #13


Web Design Seo
****

Group: Root Admin
Posts: 4,161
Joined: 29-April 09
From: Sofia
Member No.: 1



In this component are no pop-ups. What is your version of joomla and component? And where you want to post - in content, k2, kunena or jomsocial?


--------------------
Правила на форума | Forum Rules | How to receive support. 3D Web Design: Уеб дизайн, Seo оптимизация, Web Site Extensions, Oscommerce Addons, Wordpress plugins and Joomla Extensions. Изработка на уеб сайтове и оптимизация на сайт за търсачки и Seo услуги.
Go to the top of the page
 
+Quote Post
kibangkok
post Feb 15 2013, 07:30 AM
Post #14


Newbie
*

Group: Members
Posts: 5
Joined: 20-July 12
From: thailand
Member No.: 1,281



QUOTE (Web Design Seo @ Feb 15 2013, 08:23 AM) *
In this component are no pop-ups. What is your version of joomla and component? And where you want to post - in content, k2, kunena or jomsocial?


thank you very much for your quick reply.
i use Joomla 2.5.9. i install post_by_email_pro_1.7.4 for joomla 2.5.zip .
i use it only for joomla content. i have not used K2. do i still neet to install K2?
Go to the top of the page
 
+Quote Post
Web Design Seo
post Feb 15 2013, 08:25 AM
Post #15


Web Design Seo
****

Group: Root Admin
Posts: 4,161
Joined: 29-April 09
From: Sofia
Member No.: 1



Цитат
do i still neet to install K2?

No.

We may need access to your website to solve your problem. Joomla admin access and ftp are required if you want to find and solve problem.


--------------------
Правила на форума | Forum Rules | How to receive support. 3D Web Design: Уеб дизайн, Seo оптимизация, Web Site Extensions, Oscommerce Addons, Wordpress plugins and Joomla Extensions. Изработка на уеб сайтове и оптимизация на сайт за търсачки и Seo услуги.
Go to the top of the page
 
+Quote Post
kibangkok
post Feb 15 2013, 08:34 AM
Post #16


Newbie
*

Group: Members
Posts: 5
Joined: 20-July 12
From: thailand
Member No.: 1,281



Цитат(Web Design Seo @ Feb 15 2013, 09:25 AM) *
No.

We may need access to your website to solve your problem. Joomla admin access and ftp are required if you want to find and solve problem.


thanks for your prompt support. i will give you my access to my web to you mail box.

hi.. i found my problem. i found that there is data for the root of database on category.
i add the root data and after that the problem suddently disappear.

now i can use it as normal. thank any way for your advise.
Reason for edit: edited
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

Collapse

> Similar Topics

  Topic Replies Topic Starter Views Last Action
No new Posts By Email Not Processing Correct After 1.9.5 Update
12 livewiremaxx 4,432 20th April 2014 - 05:38 PM
Last post by: livewiremaxx
No New Posts Correct Scrape Of Section
1 Juan Vicente Pascual 2,267 20th June 2013 - 08:09 AM
Last post by: Web Design Seo


 



RSS Lo-Fi Version Time is now: 19th October 2019 - 12:20 AM
Clicky Web Analytics