Welcome Guest ( Log In | Register )

 Forum Rules Extensions Support
 
Reply to this topicStart new topic
> Post By Email Pro Article Empty And Kunena Error, [solved]
dbass
post Apr 20 2012, 05:52 PM
Post #1


Newbie
*

Group: Members
Posts: 2
Joined: 20-April 12
Member No.: 1,159



Hi,

I recently bought Post by email pro and have some troubles. I run Joomla 2.5

After sending the mail, I receive it in the category I choosed, but only have the title (subject of the mail). When I open the article, it is empty... sad.gif (I send html mail, not plain text, which seems to be ok)

I also tried to post by email in Kuena forum, but without more success dry.gif . My Kuena forum is not public access, but registered. I have an error message:

Код
***ERROR (com_kunena) Unable to add post: COM_KUNENA_POST_FIELD_REQUIRED
1 emails imported (Régie) in 1 seconds.


It says 1 email imported but there is nothing new in the forum
Go to the top of the page
 
+Quote Post
Ivan Stamenov
post Apr 21 2012, 10:44 AM
Post #2


Advanced User
****

Group: Advanced Member
Posts: 218
Joined: 15-April 11
Member No.: 761



Цитат(dbass @ Apr 20 2012, 05:52 PM) *
Hi,

I recently bought Post by email pro and have some troubles. I run Joomla 2.5

After sending the mail, I receive it in the category I choosed, but only have the title (subject of the mail). When I open the article, it is empty... sad.gif (I send html mail, not plain text, which seems to be ok)

I also tried to post by email in Kuena forum, but without more success dry.gif . My Kuena forum is not public access, but registered. I have an error message:

Код
***ERROR (com_kunena) Unable to add post: COM_KUNENA_POST_FIELD_REQUIRED
1 emails imported (Régie) in 1 seconds.


It says 1 email imported but there is nothing new in the forum



Hi, dbass.

The problem in both cases seems to be the missing message's content, obviously sad.gif.

Please send a test e-mail to test_test@3dwebdesign.org in order to investigate the format of your e-mails and the behaviour of our message parser. When you do, please write us a notice... Meanwhile I remain with

Best regards,

Ivan
Go to the top of the page
 
+Quote Post
dbass
post Apr 21 2012, 12:28 PM
Post #3


Newbie
*

Group: Members
Posts: 2
Joined: 20-April 12
Member No.: 1,159



QUOTE (Ivan Stamenov @ Apr 21 2012, 12:44 PM) *
Hi, dbass.

The problem in both cases seems to be the missing message's content, obviously sad.gif.

Please send a test e-mail to test_test@3dwebdesign.org in order to investigate the format of your e-mails and the behaviour of our message parser. When you do, please write us a notice... Meanwhile I remain with

Best regards,

Ivan


Hi,

I have just sent a test message to test_test@3dwebdesign.org. I run on MacOS X 10.6 with excellent Sparrow Mail client. In my client, I have a lot of addresses configured, but I use Gmail accounts...

Thank you for your help.

This post has been edited by dbass: Apr 21 2012, 12:29 PM
Go to the top of the page
 
+Quote Post
Ivan Stamenov
post Apr 23 2012, 09:02 AM
Post #4


Advanced User
****

Group: Advanced Member
Posts: 218
Joined: 15-April 11
Member No.: 761



Цитат(dbass @ Apr 21 2012, 12:28 PM) *
Hi,

I have just sent a test message to test_test@3dwebdesign.org. I run on MacOS X 10.6 with excellent Sparrow Mail client. In my client, I have a lot of addresses configured, but I use Gmail accounts...

Thank you for your help.


Hi, Dbass!

It was my bad. I've overlooked a possible use of content-disposition: inline blink.gif , for which I would like to apologise. You may either download the updated version of PBM or you can fix it manually:

Open /administrator/components/com_post_by_email/controller.php

Depending on the Joomla version, around line 590 (Joomla 1.5) or line 437 (Joomla 1.6-2.5) there is the following code (3 lines):

Код
if ('attachment' == $disposition || 'inline' == $disposition || (!empty($content_type) && in_array($content_type, $accepted_attachment_types))) {
    if (!in_array($content_type, $accepted_attachment_types) || !in_array($transfer_encoding, $accepted_attachment_encodings))
        return;


Please replace it with the following:

Код
if (('attachment' == $disposition || 'inline' == $disposition) && !empty($content_type) && in_array($content_type, $accepted_attachment_types)) {
    if (!in_array($transfer_encoding, $accepted_attachment_encodings))
        return;



Edited on 24.04.2012:
In the same file search for

Код
require_once (KUNENA_PATH_LIB . DS . 'kunena.posting.class.php');


Above it please insert:

Код
require_once (JPATH_SITE.DS.'includes'.DS.'application.php');

End of the edit note


Thank you very much for your feedback. I remain with

Best regards,

Ivan
Go to the top of the page
 
+Quote Post
Web Design Seo
post Apr 23 2012, 09:05 AM
Post #5


Web Design Seo
****

Group: Root Admin
Posts: 4,165
Joined: 29-April 09
From: Sofia
Member No.: 1



Problem is solved. Both versions of extension (joomla 2.5 and j1.5) have updated with this fix and are already uploaded in our website.


--------------------
Правила на форума | Forum Rules | How to receive support. 3D Web Design: Уеб дизайн, Seo оптимизация, Web Site Extensions, Oscommerce Addons, Wordpress plugins and Joomla Extensions. Изработка на уеб сайтове и оптимизация на сайт за търсачки и Seo услуги.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

Collapse

> Similar Topics

  Topic Replies Topic Starter Views Last Action
No New Posts Post By Email To K2 Images Not Resizing
1 bossies 5,464 31st May 2019 - 10:49 AM
Last post by: Web Design Seo
No New Posts Post By Email Pro - Cron Warnings
JROUTER_MODE warnings
1 Brian Craigie 5,678 31st January 2019 - 08:42 AM
Last post by: Web Design Seo
No New Posts Post By Email, Error 500
500 error on backend
1 galamarco 5,077 17th January 2019 - 06:29 AM
Last post by: Web Design Seo
No new Pinned: Topic has attachmentsPost By Email Pro
Pro version of Post By Email component
113 Ivan Stamenov 100,429 17th January 2019 - 06:28 AM
Last post by: Web Design Seo
No New Posts Error [111] [connection Refused]
[solved]
2 Jan van Kuijk 18,709 17th September 2016 - 07:13 AM
Last post by: Jan van Kuijk
No new Post By Email Not Working Since Joomla 3.5.0 Update [solved]
5 tompuchner 22,655 2nd May 2016 - 07:04 AM
Last post by: Web Design Seo
No New Posts Post By Email Using Mms On A Mobile Phone
1 alexilio 14,084 13th April 2016 - 09:44 AM
Last post by: Web Design Seo
No New Posts Post By Email Jomsocial - Unable To Post To Wall
3 uglykidjoe 9,652 11th February 2016 - 07:25 AM
Last post by: Web Design Seo
No New Posts Pinned: Android Tv Box
Андроид ТВ бокс устройства, какво е това
0 Web Design Seo 16,798 21st December 2015 - 09:52 AM
Last post by: Web Design Seo
No New Posts Post By Email Doesn't Works
1 cranky69 15,867 1st December 2015 - 10:30 AM
Last post by: Web Design Seo


 



RSS Lo-Fi Version Time is now: 14th November 2019 - 04:47 AM
Clicky Web Analytics