Welcome Guest ( Log In | Register )

 Forum Rules Extensions Support
 
Reply to this topicStart new topic
> Mailorder Pro Problem
blondaas
post Oct 26 2011, 07:16 PM
Post #1


Newbie
*

Group: Members
Posts: 3
Joined: 26-October 11
Member No.: 942



Hello,

I have Joomla 1.7 and Mailorder Pro installed. All set up according to guide. Link created, I am using default template. After submitting form I am getting two messages:
"It is not possible to e-mail address to send!" and Product Unknown!. No other errors. I have also BreezingForms component installed.

Any idea how to make this working?

Thanks
Go to the top of the page
 
+Quote Post
Ivan Stamenov
post Oct 27 2011, 02:28 PM
Post #2


Advanced User
****

Group: Advanced Member
Posts: 218
Joined: 15-April 11
Member No.: 761



Цитат(blondaas @ Oct 26 2011, 08:16 PM) *
Hello,

I have Joomla 1.7 and Mailorder Pro installed. All set up according to guide. Link created, I am using default template. After submitting form I am getting two messages:
"It is not possible to e-mail address to send!" and Product Unknown!. No other errors. I have also BreezingForms component installed.

Any idea how to make this working?

Thanks


Dear blondaas,

You get the "Product Unknown" message when the content item ID you set in your article is incorrect and the component is unable to get the needed information.
You get the "Unable to send the e-mail" message when your Joomla is not properly configured in order to send e-mails (JUtility::sendMail fails) or when the product link points outside your site (JURI::isInternal($link) returns false).

Please check these options...
Go to the top of the page
 
+Quote Post
blondaas
post Oct 27 2011, 10:48 PM
Post #3


Newbie
*

Group: Members
Posts: 3
Joined: 26-October 11
Member No.: 942



QUOTE (Ivan Stamenov @ Oct 27 2011, 03:28 PM) *
Dear blondaas,

You get the "Product Unknown" message when the content item ID you set in your article is incorrect and the component is unable to get the needed information.
You get the "Unable to send the e-mail" message when your Joomla is not properly configured in order to send e-mails (JUtility::sendMail fails) or when the product link points outside your site (JURI::isInternal($link) returns false).

Please check these options...


The thing is that on initial pop-up page product name is displayed properly. After submission I am getting both errors. Site is till located on dev sever accessed by ip+path only. $live_site path is set, other components can send emails. Do you think that accessing website not using domain name cause the problem? I have made a test on other site, both components work fine together.
Go to the top of the page
 
+Quote Post
Web Design Seo
post Oct 28 2011, 09:16 AM
Post #4


Web Design Seo
****

Group: Root Admin
Posts: 4,161
Joined: 29-April 09
From: Sofia
Member No.: 1



Цитат(blondaas @ Oct 28 2011, 01:48 AM) *
The thing is that on initial pop-up page product name is displayed properly. After submission I am getting both errors. Site is till located on dev sever accessed by ip+path only. $live_site path is set, other components can send emails. Do you think that accessing website not using domain name cause the problem? I have made a test on other site, both components work fine together.


Problem is only configuration of your email server. $live_site path and accessing website over ip are not the problems. We have over ten vps servers and i know that configuration of mail server is hard - on some custom servers we have only one way to use email in joomla.


1. If your joomla send emails, check the way how its work in global config in joomla. Try to use other way (the ways are sendmail, php function and smtp) Is good idea to use in component exact email box that you know that work.
2. We have cases on custom servers that joomla send emails to some email box, bit to other email box not - emails are not received. Why? Some host companies have spam filters. You send email from email address like: email@site.com. Email from ip xxxxxx (your server) is marked like spam because domain name site.com is not attached to ip of your server.


--------------------
Правила на форума | Forum Rules | How to receive support. 3D Web Design: Уеб дизайн, Seo оптимизация, Web Site Extensions, Oscommerce Addons, Wordpress plugins and Joomla Extensions. Изработка на уеб сайтове и оптимизация на сайт за търсачки и Seo услуги.
Go to the top of the page
 
+Quote Post
blondaas
post Oct 30 2011, 04:49 PM
Post #5


Newbie
*

Group: Members
Posts: 3
Joined: 26-October 11
Member No.: 942



QUOTE (Web Design Seo @ Oct 28 2011, 09:16 AM) *
Problem is only configuration of your email server. $live_site path and accessing website over ip are not the problems. We have over ten vps servers and i know that configuration of mail server is hard - on some custom servers we have only one way to use email in joomla.


1. If your joomla send emails, check the way how its work in global config in joomla. Try to use other way (the ways are sendmail, php function and smtp) Is good idea to use in component exact email box that you know that work.
2. We have cases on custom servers that joomla send emails to some email box, bit to other email box not - emails are not received. Why? Some host companies have spam filters. You send email from email address like: email@site.com. Email from ip xxxxxx (your server) is marked like spam because domain name site.com is not attached to ip of your server.



Ok, I tried php mail and smtp method to send emails. Both methods worked fine for other component forms (BreezingForms), I have received emails. But still cant send email by mailorder. Same message "It is not possible to e-mail address to send!".

I've set error reporting to max:
Notice: Undefined index: text/javascript in /home/pdqmachi/public_html/plugins/content/mailorder/mailorder.php on line 51

I 've updated Joomla to the latest version, reinstalled your component and still no results sad.gif I am completely lost and out of ideas.
Go to the top of the page
 
+Quote Post
Web Design Seo
post Oct 31 2011, 07:28 AM
Post #6


Web Design Seo
****

Group: Root Admin
Posts: 4,161
Joined: 29-April 09
From: Sofia
Member No.: 1



Idea is to test sending of emails to different email boxes - once for admin, other time to other email. If again not working, create one temporary admin account for us to see problem in your site and send login data to our email.


--------------------
Правила на форума | Forum Rules | How to receive support. 3D Web Design: Уеб дизайн, Seo оптимизация, Web Site Extensions, Oscommerce Addons, Wordpress plugins and Joomla Extensions. Изработка на уеб сайтове и оптимизация на сайт за търсачки и Seo услуги.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

Collapse

> Similar Topics

  Topic Replies Topic Starter Views Last Action
No New Posts Mailorder In Costum Module
1 Robert Johansson 5,125 2nd July 2018 - 06:46 AM
Last post by: Web Design Seo
No New Posts Mailorder Pro Plugin Blank Form In Internet Explorer 9
mailorder pro plugin blank form in internet explorer 9
3 rajinfosys 11,174 27th February 2017 - 10:25 AM
Last post by: Web Design Seo
No New Posts Mailorder's Custom Product Name
i try to change mailorder's product name with given parameter like
1 Palindrom 2,464 11th November 2013 - 02:09 PM
Last post by: pavelKukov
No New Posts Problem Downloading The Trial Version
1 maupap 3,099 23rd October 2013 - 07:42 AM
Last post by: Web Design Seo
No new Problems With Post By Email Component
5 alex.mendez 4,415 15th October 2013 - 06:03 AM
Last post by: Web Design Seo
No New Posts Mailorder In A Module
1 webed 2,794 26th September 2013 - 06:02 AM
Last post by: Web Design Seo
No New Posts Problem With Viewing My Site In Mobile
0 -Jason Foster- 17,959 1st September 2013 - 03:53 PM
Last post by: Jason Foster
No new Problem With Microformats
4 dianaNashif 4,657 16th June 2013 - 07:50 AM
Last post by: Web Design Seo
No new Topic has attachmentsProblems Importing Mail With Post By Email
support questions for Post By Email Pro
125 Web Design Seo 32,621 28th May 2013 - 10:58 AM
Last post by: Kovács Gergely
No new Topic has attachmentsProblem With Importing Image Into K2 Image Tab Joomla 2.5
Problem with importing image into K2 image tab joomla 2.5
45 sdbit 17,067 9th April 2013 - 01:49 PM
Last post by: Web Design Seo


 



RSS Lo-Fi Version Time is now: 17th October 2019 - 01:08 AM
Clicky Web Analytics