Help - Search - Members - Calendar
Full Version: Sh404sef - не запазва настройки
Web Design Seo Forum > Уеб дизайн Seo Форум > sh404sef
Rosen Ivanov
Здравейте,

ЗА МНОГО ГОДИНИ!!!

Срещнах проблем при изграждането на един нов сайт. Използвам моднатата версия на sh404sef - за работа с адреси на кирилица.

Проблемът е, че не мога да запаметя никаква настройка на sh404sef. Просто при запис мен праща към # и толкова. Има моменти, в които работи, но честно казано не мога да ги назова точно какви са тези моменти. Опитвам да трия кеш, но и това не помага.

В момента сеф адресите са пуснати отпреди и си се генерират/трият и т.н. Но опитвам да пусна Мета генерерирането или да спра изцяло компонента и неще. Изобщо каквото и да е от настройките не реагира.

Някакви идеи от какво може да се получава ?!?!

Web Design Seo
ЗА МНОГО ГОДИНИ!

Нормално компонента няма такива проблеми.

Проверете дали папките ви имат права за писане и дали конфиг файла на sh404sef също може да бъде презаписан. Щом понякога работи, понякога не: може сайта ви да е станал доста тежък и да не му достига памет, трябва да е настроен да работи с не по-малко от 64 мб памет.
Rosen Ivanov
Цитат(Web Design Seo @ Jan 3 2012, 01:54 PM) *
Нормално компонента няма такива проблеми.

Проверете дали папките ви имат права за писане и дали конфиг файла на sh404sef също може да бъде презаписан. Щом понякога работи, понякога не: може сайта ви да е станал доста тежък и да не му достига памет, трябва да е настроен да работи с не по-малко от 64 мб памет.


Така е. До сега на още три сайта не съм имал никакви проблеми и за това ми е странно какво се случва.

- Всички папки са 755, а файловете 644.
- sh404SEF Configuration - Writeable
- Това с работенето тотално приключи. Вече въобще не работи и нищо не мога да направя. Колкото до тежестта - сайта сега го правя и има всичко на всичко - 30-тина урл-а. Не вярвам да е от това. Иначе за настройването на паметта не съм си играл, но и другите три сайта, на които компонента работи са на същия хостинг.
Web Design Seo
Вероятно във вас е проблема значи, в настройките на точно този сайт. Иначе това сигурно сте го чели: как да настроя sh404sef
Rosen Ivanov
Цитат(Web Design Seo @ Jan 3 2012, 02:09 PM) *
Вероятно във вас е проблема значи, в настройките на точно този сайт. Иначе това сигурно сте го чели: как да настроя sh404sef


Да, това съм го чел и всичко е настроено. Само остава да разбера и от къде идва проблема!
Web Design Seo
Първо прегледайте настройките на php - версия, мемори лимит и други и ги сравнете с тези на сайтовете където работи ок. Ако няма разлики - Error reporting на макс и тестване.
Rosen Ivanov
Мисля, че в php.ini-то няма проблем. Аз основното .ини не съм го бутал, а в руут-овете на другите сайтове ини-та са с:

CODE
error_log=error_log
memory_limit = 64M
log_errors=On
error_reporting = E_ALL & ~E_NOTICE
expose_php = Off
output_buffering = Off
max_input_time = 60
safe_mode=off
variables_order = "EGPCS"
extension_dir = "./"
register_globals=Off
allow_url_fopen=Off
allow_url_include=Off
disable_functions=show_source, system, shell_exec, passthru, exec, phpinfo, popen, proc_open


Пуснах ерор репорта - и идинсвеното, което ми изкара бе за някаква картинка, но го оправих това. И нищо друго не се генерира в error_log файла.

Почвам да си мисля, дали проблема не е от шаблона нещо, тъй като използва JA T3 V2 Framework. Дали това може да бърка нещата или не би трябвало да има общо. Защото това на пръв поглед е единствената разлика с другите.

*Едит: След като постнах реших да направя проба и изключих на JA Framework-а, смених и темплейта, изтрих кеш на Д!, кеш на браузера .... и пак не става! Не знам какво да пробвам вече.
Rosen Ivanov
Здравейте отново,

Тъй като след дълго лутане открих проблема, та реших да го споделя. Все пак може и някой друг да си блъска главата.

Естествено проблема се оказа изключително глупав! Всичко идва от браузъра - FF /v. 10.0 beta/. След дълго тестване и експериментиране се бях отчаял, но установих впоследствие че от др. бразузери работи. Не зная дали причината е в това, че е бета версия, но определено има някакъв проблем. Изчистване на кеш, кукита и прочие не помага. Просто не иска да работи и това е!

Web Design Seo
Това е изключително необмислено - не ъпдейтвайте мозила файърфокс често, аз още съм с версия 7. Ако го ъпдейтвате, ще спрат да ви работят и добавките, макар че има начин това да се прескочи с редактирането на ръка на някои от добавките.


И те умните хора по цял свят са си го казали: има един браузер - Опера. Всички други само гледат и копират от него smile.gif
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2019 Invision Power Services, Inc.

Web Analytics