Help - Search - Members - Calendar
Full Version: Cron With Post By Email
Web Design Seo Forum > 3D Web Design English Forum > Joomla Extensions
livewiremaxx
I have post by Email working fine from the back end of Joomla. It will import just fine if I select the box to import
BUT running Cron it wont do the import. I think it worked for a day or so and then it stopped. I run the server its on so already checked for error and its not giving any.

So my Cron line seems correct

QUOTE
*/5 * * * *
/usr/bin/php -q /home/scan/public_html/administrator/components/com_post_by_email/cron.post_by_email.php >> /dev/null


Log output with no error
QUOTE
Sep 18 05:24:01 host crond[15675]: (scan) CMD (/usr/bin/php -q /home/scan/public_html/administrator/components/com_post_by_email/cron.post_by_email.php >> /dev/null)


I am at a loss now, like I said if I go in and do the import it brings in the emails just fine. Any suggestions?
Web Design Seo
Switch on error reporting at max before testing. Open post by email documentation page and read how to setup cron - way 2.

If not work, possible reason is: wrong path - ask your host support about the right path.
livewiremaxx
Sorry for the delay in response, I had to put this all on the back burner for a few weeks . 1. I run my own server and have for 15 years, so path is correct. I can get the direct import button to work fine, and I think for the most part some of the Cron is working but am getting this error from Cron Report

QUOTE
PHP Warning: session_start() [<a href='function.session-start'>function.session-start</a>]: Cannot send session cookie - headers already sent in /home/ghscan/public_html/libraries/joomla/session/session.php on line 532
PHP Warning: session_start() [<a href='function.session-start'>function.session-start</a>]: Cannot send session cache limiter - headers already sent in /home/ghscan/public_html/libraries/joomla/session/session.php on line 532
PHP Notice: Undefined index: SCRIPT_NAME in /home/ghscan/public_html/libraries/joomla/environment/uri.php on line 182
PHP Notice: Undefined index: SCRIPT_NAME in /home/ghscan/public_html/libraries/joomla/environment/uri.php on line 252
PHP Notice: Constant K2_CACHE already defined in /home/ghscan/public_html/administrator/components/com_post_by_email/helpers/importers/com_k2_init.php on line 17
PHP Notice: Constant K2_SRC already defined in /home/ghscan/public_html/administrator/components/com_post_by_email/helpers/importers/com_k2_init.php on line 18
PHP Notice: Constant K2_CACHE already defined in /home/ghscan/public_html/administrator/components/com_post_by_email/helpers/importers/com_k2_init.php on line 17
PHP Notice: Constant K2_SRC already defined in /home/ghscan/public_html/administrator/components/com_post_by_email/helpers/importers/com_k2_init.php on line 18
PHP Notice: Constant K2_CACHE already defined in /home/ghscan/public_html/administrator/components/com_post_by_email/helpers/importers/com_k2_init.php on line 17
PHP Notice: Constant K2_SRC already defined in /home/ghscan/public_html/administrator/components/com_post_by_email/helpers/importers/com_k2_init.php on line 18
PHP Notice: Constant K2_CACHE already defined in /home/ghscan/public_html/administrator/components/com_post_by_email/helpers/importers/com_k2_init.php on line 17
PHP Notice: Constant K2_SRC already defined in /home/ghscan/public_html/administrator/components/com_post_by_email/helpers/importers/com_k2_init.php on line 18
PHP Notice: Constant K2_CACHE already defined in /home/ghscan/public_html/administrator/components/com_post_by_email/helpers/importers/com_k2_init.php on line 17
PHP Notice: Constant K2_SRC already defined in /home/ghscan/public_html/administrator/components/com_post_by_email/helpers/importers/com_k2_init.php on line 18
PHP Notice: Constant K2_CACHE already defined in /home/ghscan/public_html/administrator/components/com_post_by_email/helpers/importers/com_k2_init.php on line 17
PHP Notice: Constant K2_SRC already defined in /home/ghscan/public_html/administrator/components/com_post_by_email/helpers/importers/com_k2_init.php on line 18
PHP Notice: Constant K2_CACHE already defined in /home/ghscan/public_html/administrator/components/com_post_by_email/helpers/importers/com_k2_init.php on line 17
PHP Notice: Constant K2_SRC already defined in /home/ghscan/public_html/administrator/components/com_post_by_email/helpers/importers/com_k2_init.php on line 18
PHP Notice: Constant K2_CACHE already defined in /home/ghscan/public_html/administrator/components/com_post_by_email/helpers/importers/com_k2_init.php on line 17
PHP Notice: Constant K2_SRC already defined in /home/ghscan/public_html/administrator/components/com_post_by_email/helpers/importers/com_k2_init.php on line 18



QUOTE (Web Design Seo @ Sep 18 2013, 04:56 PM) *
Switch on error reporting at max before testing. Open post by email documentation page and read how to setup cron - way 2.

If not work, possible reason is: wrong path - ask your host support about the right path.
pavelKukov
Please, tell me versions of post_by_email, joomla and php?
Dominicfr
Hi there, I also have a problem to set cron task for post by email.
setting email accounts and import in the admin page is working fine but if i set a cron task thru the cpanel using:

curl -sS "http://MYWEBSITE.COM/administrator/components/com_post_by_email/cron.post_by_email.php"

I receive an email saying: 406 not acceptable

I haven't got a clue about what is happening.

I am using joomla 2.5
post_by_email_pro_1.8.0

Any idea ?
Web Design Seo
Dominicfr, Your server not support curl - is not installed or is switched off. Try cron in other way - is described in post by email documentation.

Or just send question to your host support how to activate cron jobs.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2019 Invision Power Services, Inc.

Web Analytics