Welcome Guest ( Log In | Register )

 Forum Rules Extensions Support
2 Pages V   1 2 >  
Reply to this topicStart new topic
> Kunena Integration Problems - Post By Email, [solved]
agrawal_atul
post Mar 11 2013, 05:24 AM
Post #1


Newbie
*

Group: Members
Posts: 20
Joined: 10-March 13
Member No.: 1,604



Hi

I have recently taken 'Post by Email'.
I am not to get the Kunena setup right. Import functions imports the posts in Kunena but the posts are not automatically picked up in Kunena. Do I need to some additional configuration. the current configuration view is attached.
Also during the import function, when the posts are retrieved, they all are used to create a new topic and none of them is taken as reply to an original post.

Can somebody guide me on how to make it work.

with regards
Go to the top of the page
 
+Quote Post
Web Design Seo
post Mar 11 2013, 08:08 AM
Post #2


Web Design Seo
****

Group: Root Admin
Posts: 4,161
Joined: 29-April 09
From: Sofia
Member No.: 1



You have forum and thread id to setup. Are these options right configured?


--------------------
Правила на форума | Forum Rules | How to receive support. 3D Web Design: Уеб дизайн, Seo оптимизация, Web Site Extensions, Oscommerce Addons, Wordpress plugins and Joomla Extensions. Изработка на уеб сайтове и оптимизация на сайт за търсачки и Seo услуги.
Go to the top of the page
 
+Quote Post
agrawal_atul
post Mar 11 2013, 11:28 AM
Post #3


Newbie
*

Group: Members
Posts: 20
Joined: 10-March 13
Member No.: 1,604



QUOTE (Web Design Seo @ Mar 11 2013, 01:38 PM) *
You have forum and thread id to setup. Are these options right configured?


We have followed the instruction.
the import function is working fine and it updates the posts. The post otherwise do not get updated.

How can I send you a picture of the configuration.

Go to the top of the page
 
+Quote Post
Web Design Seo
post Mar 11 2013, 11:56 AM
Post #4


Web Design Seo
****

Group: Root Admin
Posts: 4,161
Joined: 29-April 09
From: Sofia
Member No.: 1



Цитат
How can I send you a picture of the configuration.


On our email or just upload picture somewhere and post link in your post.


--------------------
Правила на форума | Forum Rules | How to receive support. 3D Web Design: Уеб дизайн, Seo оптимизация, Web Site Extensions, Oscommerce Addons, Wordpress plugins and Joomla Extensions. Изработка на уеб сайтове и оптимизация на сайт за търсачки и Seo услуги.
Go to the top of the page
 
+Quote Post
Julian
post Mar 15 2013, 07:02 AM
Post #5


Newbie
*

Group: Members
Posts: 7
Joined: 15-March 13
Member No.: 1,610



Hi everybody,

I just bought this component and it seems to be awsome. Very nice work for a very fair price, thank you!

Unfortunately, I have some challenges in setting it up. Here are some questions ... only the first one is really important, the rest is "nice-to-have". ;-)

1) When I answer to a topic with eMail, always a new thread is created. I tried all settings, I tried different subjects in the eMail and tons of stuff. It is ALWAYS creating a new topic instead of a reply. And before you ask: Sure I also have tried the setting "Post as reply" and I tested bouth settings there, just to be sure the settings are not switched by mistake).

Can you give me a hint, how the component is recognizing a reply? As I use a different language (german) maybe there is any change in the structure of the subject, that needs to be adjusted to correctly have a reply.

2) How about eMails that can´t be parsed? I really would like to have an answer to the user, so he knows if there was a problem.

3) What is the "strip-html"-setting? Do I need it?

All the best, Julian!

Go to the top of the page
 
+Quote Post
Ivan Stamenov
post Mar 15 2013, 08:08 AM
Post #6


Advanced User
****

Group: Advanced Member
Posts: 218
Joined: 15-April 11
Member No.: 761



Hi, Julian!

In order of your questions:

1) "Post as reply" must be set to "Yes" and the subject of your reply e-mail must start with either 're:' or 'fwd:' (case insensitive) + the thread's title. In such a case the PBM component will look for a thread with the given title and will add the reply to it.
E.g.: if "Post as reply" is set to yes and an e-mail with subject "Re: Yay! It's Friday!" is received, it will be added to the "Yay! It's Friday!" thread in the relevant forum.

2) This is a very good idea and probably this feature will be added in the next version. Unfortunately the current version does not support it and I don't know when the next one will pop up. However, if you or someone you know is keen in PHP, the component may be relatively easily tweaked to do this:
- add a definition of sh_t_happened($usr_mail, $error_message) function in the following file: /administrator/components/com_post_by_email/helpers/importers/com_kunena_init.php. This function will send the $error_message error message to the $usr_mail e-mail address.
- look in the /administrator/components/com_post_by_email/helpers/importers/com_kunena.php file. There are several $this->_output['err'][] = {error message} statements which gets executed when... sh_t happens. Append after these the relevant call to the mail sending function: sh_t_happened($usr_mail, {error message}). Note that the $usr_mail variable is already containing the message author's e-mail address at this point - there is no need to search for it.

3) If set to yes, the "Strip HTML tags" setting will use the PHP's strip_tags() function to remove all the HTML markup from the message's body prior to storing it in the database. As the e-mail will be posted to a forum thread, I think it is a good idea to turn it on.

Best regards,

Ivan
Go to the top of the page
 
+Quote Post
Julian
post Mar 15 2013, 08:55 AM
Post #7


Newbie
*

Group: Members
Posts: 7
Joined: 15-March 13
Member No.: 1,610



Hi Ivan,
QUOTE (Ivan Stamenov @ Mar 15 2013, 09:08 AM) *
1) "Post as reply" must be set to "Yes" and the subject of your reply e-mail must start with either 're:' or 'fwd:' (case insensitive) + the thread's title. In such a case the PBM component will look for a thread with the given title and will add the reply to it.
E.g.: if "Post as reply" is set to yes and an e-mail with subject "Re: Yay! It's Friday!" is received, it will be added to the "Yay! It's Friday!" thread in the relevant forum.


Oh, then it is obvious and it should be easy to solve:
I live in germany and most emails have "AW:" or "WG:" in front.

In Terms of Multilingual I would suggest to create an option so the admin can freely change the "re" and adjust it to his needs.
However, is there a quick way I can add the german stuff too?

And about the topic:
The recent Kunena-version adds [Forumname] before the thread-title and (category) at the end of the subject of the eMail-notification.
Does PBEM sort that out or do I need to change the eMail-templates of kunena?

All the best, Julian!
Go to the top of the page
 
+Quote Post
agrawal_atul
post Mar 16 2013, 03:05 PM
Post #8


Newbie
*

Group: Members
Posts: 20
Joined: 10-March 13
Member No.: 1,604



Hi

We have realized that we need a cron job to support the feature to transfer mail auotmatically. Unfortuntely, out webhosting service provider does not support cron jobs. We though have a separate linux server (virtual server) which does support cron jobs. Can we set up a cron job on a linux server such that a job can be run on the web hosting server. Can you help us in the process. We are sorry that we are asking something which is outside the support scope. We would highly appreciate any support which you can provide us.

with regards
Go to the top of the page
 
+Quote Post
Web Design Seo
post Mar 18 2013, 06:34 AM
Post #9


Web Design Seo
****

Group: Root Admin
Posts: 4,161
Joined: 29-April 09
From: Sofia
Member No.: 1



agrawal_atul, You have file that is accesibel over url
Код
http://your-post-by-email-site.com/administrator/components/com_post_by_email/cron.post_by_email.php


and min. two ways to schedule crons:
Код
curl -sS "http://your-post-by-email-site.com/administrator/components/com_post_by_email/cron.post_by_email.php" >> /dev/null


or:
Код
/usr/local/bin/php -q /relative path to host directory/public_html/administrator/components/com_post_by_email/cron.post_by_email.php >> /dev/null


You can call cron url from every host account that support curl. For example, i have over 20 sites with crons needed to call from url but my hosting company don't have curl activated and i have configure these all over 20 sites in cpanel of other hosting company that support curl.


--------------------
Правила на форума | Forum Rules | How to receive support. 3D Web Design: Уеб дизайн, Seo оптимизация, Web Site Extensions, Oscommerce Addons, Wordpress plugins and Joomla Extensions. Изработка на уеб сайтове и оптимизация на сайт за търсачки и Seo услуги.
Go to the top of the page
 
+Quote Post
agrawal_atul
post Mar 18 2013, 05:22 PM
Post #10


Newbie
*

Group: Members
Posts: 20
Joined: 10-March 13
Member No.: 1,604



[quote name='Web Design Seo' date='Mar 18 2013, 12:04 PM' post='5776']
agrawal_atul, You have file that is accesibel over url
CODE
http://your-post-by-email-site.com/administrator/components/com_post_by_email/cron.post_by_email.php


Hi

I have setup a cron job on an external hosting service provider.
My cron job is curl -sS "http://www.smartcommunity.in/society/administrator/components/com_post_by_email/cron.post_by_email.php" >> /dev/null

I have changed the file access to 755.
I do not see any thing happening. I am also not getting any error mail. Please suggest if there is a way to see if I have configured everything correctly.


This post has been edited by agrawal_atul: Mar 18 2013, 07:38 PM
Go to the top of the page
 
+Quote Post
agrawal_atul
post Mar 18 2013, 08:38 PM
Post #11


Newbie
*

Group: Members
Posts: 20
Joined: 10-March 13
Member No.: 1,604



Hi

We modified the controller.php and cron.post_by_email.php to get the cron job working.

I however am having following issues:
(A) If I click 'Transfer', all the mails are read and posted in Kunena. However, they are posted as new topics
(cool.gif If I directly run cron.post_by_email.php or run the cron job, the cron runs (the mails in the mailbox get deleted as per the set option). However the mails are not posted to the Kunena forum. We see the following error if we directly run the cron job:

RE: [Society Forum] Test post (Suggestion Box): ***ERROR (com_kunena) Unable to post message: Cannot save topic: Category 0 doesn't exist! 0 emails were processed (Publish a Notice) in 0 seconds. 1 emails were processed (societyforum) in 0 seconds.

Please help us to resolve these two issues.
Go to the top of the page
 
+Quote Post
Web Design Seo
post Mar 19 2013, 08:53 AM
Post #12


Web Design Seo
****

Group: Root Admin
Posts: 4,161
Joined: 29-April 09
From: Sofia
Member No.: 1



There is no such a issue with component. You may be have broke something in code. If you are configured the right id of category that is not locked, emails must be imported.

Цитат
I do not see any thing happening. I am also not getting any error mail. Please suggest if there is a way to see if I have configured everything correctly.


First test manual import. Run cron only after you see that manual import work well.


--------------------
Правила на форума | Forum Rules | How to receive support. 3D Web Design: Уеб дизайн, Seo оптимизация, Web Site Extensions, Oscommerce Addons, Wordpress plugins and Joomla Extensions. Изработка на уеб сайтове и оптимизация на сайт за търсачки и Seo услуги.
Go to the top of the page
 
+Quote Post
agrawal_atul
post Mar 19 2013, 09:09 AM
Post #13


Newbie
*

Group: Members
Posts: 20
Joined: 10-March 13
Member No.: 1,604



QUOTE (Web Design Seo @ Mar 19 2013, 02:23 PM) *
There is no such a issue with component. You may be have broke something in code. If you are configured the right id of category that is not locked, emails must be imported.



First test manual import. Run cron only after you see that manual import work well.


The manual import works. It just creates a new post in the same category. It does not post it as a reply.

As far as the cron job is concerned, the job runs (the mail from the email folder) get removed but the mail is not posted on the forum.

we have hardly touched the code (only to allow external cron job). Can we give you access to the site where you can check.
Go to the top of the page
 
+Quote Post
Web Design Seo
post Mar 19 2013, 09:19 AM
Post #14


Web Design Seo
****

Group: Root Admin
Posts: 4,161
Joined: 29-April 09
From: Sofia
Member No.: 1



Post as a reply depend on "re", "fwd" and other standart phrases. Today we will have new version with option to configure your own rules about this function.

Subscibe for this topic and when new version is released update from your account component.


P.S. Seems that kunena team have made some changes in latest Kunena (again). New version of Post By Email that support latest version of Kunena will be released today.


--------------------
Правила на форума | Forum Rules | How to receive support. 3D Web Design: Уеб дизайн, Seo оптимизация, Web Site Extensions, Oscommerce Addons, Wordpress plugins and Joomla Extensions. Изработка на уеб сайтове и оптимизация на сайт за търсачки и Seo услуги.
Go to the top of the page
 
+Quote Post
Ivan Stamenov
post Mar 19 2013, 10:13 AM
Post #15


Advanced User
****

Group: Advanced Member
Posts: 218
Joined: 15-April 11
Member No.: 761



Цитат(Julian @ Mar 15 2013, 08:55 AM) *
Hi Ivan,


Oh, then it is obvious and it should be easy to solve:
I live in germany and most emails have "AW:" or "WG:" in front.

In Terms of Multilingual I would suggest to create an option so the admin can freely change the "re" and adjust it to his needs.
However, is there a quick way I can add the german stuff too?

And about the topic:
The recent Kunena-version adds [Forumname] before the thread-title and (category) at the end of the subject of the eMail-notification.
Does PBEM sort that out or do I need to change the eMail-templates of kunena?

All the best, Julian!


Hi, Julian!

I've added a new setting in the admin (Reply tag), now you are able to set what the reply emails' subjects must start with. You may set this to AW, WG, RE, FWD or whatever you want. If an email subject starts with AW:, wg:, Re: or fWd: (case insensitive), the message will be threatened as a reply to the relevant topic.

About your second question - PBEM uses the Kunena's $message->sendNotification() function, so you should not have to modify the e-mail templates....

Best regards,
Ivan


New version is uploaded and available for download.
Go to the top of the page
 
+Quote Post
agrawal_atul
post Apr 1 2013, 02:54 PM
Post #16


Newbie
*

Group: Members
Posts: 20
Joined: 10-March 13
Member No.: 1,604



Hi

I have had some discussion on you on support but I am not convinced.

Please confirm that the reply in Kunena would always come in as new post and PBM can not parse the forum name and category in the reply email message to Kunena.

I wonder how anybody uses reply to post function in Kunena integration.
Go to the top of the page
 
+Quote Post
Web Design Seo
post Apr 2 2013, 06:59 AM
Post #17


Web Design Seo
****

Group: Root Admin
Posts: 4,161
Joined: 29-April 09
From: Sofia
Member No.: 1



Posting as reply in Kunena work if email is sent by human and formatted in the same way as configuration option "Reply tag":



--------------------
Правила на форума | Forum Rules | How to receive support. 3D Web Design: Уеб дизайн, Seo оптимизация, Web Site Extensions, Oscommerce Addons, Wordpress plugins and Joomla Extensions. Изработка на уеб сайтове и оптимизация на сайт за търсачки и Seo услуги.
Go to the top of the page
 
+Quote Post
pavelKukov
post Apr 2 2013, 01:22 PM
Post #18


Php programmer
****

Group: Administrators
Posts: 285
Joined: 26-November 12
From: Bulgaria
Member No.: 1,452



Цитат
Please confirm that the reply in Kunena would always come in as new post and PBM can not parse the forum name and category in the reply email message to Kunena.


No. That is not the case. Post By Email can parse the forum name and category but you need to set right message prefix in Reply tag:

I have tested this with kunena 2.0.4 and post_by_email_pro_1.7.7 for joomla 2.5-new kunena support. My configuration for replay tag is as follows

Reply tag: Re, Fwd, [Kunena]



--------------------
Php programmer in 3D Web Design
Go to the top of the page
 
+Quote Post
agrawal_atul
post Apr 2 2013, 10:06 PM
Post #19


Newbie
*

Group: Members
Posts: 20
Joined: 10-March 13
Member No.: 1,604



QUOTE (pavelKukov @ Apr 2 2013, 06:52 PM) *
No. That is not the case. Post By Email can parse the forum name and category but you need to set right message prefix in Reply tag:

I have tested this with kunena 2.0.4 and post_by_email_pro_1.7.7 for joomla 2.5-new kunena support. My configuration for replay tag is as follows

Reply tag: Re, Fwd, [Kunena]


Hi
I have tried this configuration as well as some other combinations. We are able to parse Re tag successfully if the forum name and category names are excluded from the subject.
We are not able to parse forum name even though we remove the category name from the subject. I am pasting here the configuration as well as forum screen shot. Please see that reply is resulting into a new post.




This post has been edited by agrawal_atul: Apr 2 2013, 10:32 PM
Go to the top of the page
 
+Quote Post
agrawal_atul
post Apr 6 2013, 11:31 AM
Post #20


Newbie
*

Group: Members
Posts: 20
Joined: 10-March 13
Member No.: 1,604



Folks

I would appreciate a quick response.
The response in support told me that Kunena - Email - Kunena integration is not possible. I then gave my perspective that then there is no value of Kunena integration. I also asked why then reply tag has been included in the configuration. I never got a response to that mail till day.
When I submit the issue on forum, I get a response that PBM can read the Kunena reply mail.

I am firstly surprised by the contradictions in the responses. Can somebody give a formal response on whether PBM can read Kunena reply parse forum.

In addition, I am still waiting for an answer on why our conifiguration is not working and why it is not able to parse forum name from the reply message. Of course we still need to see how it parses the category name.

with regards
Go to the top of the page
 
+Quote Post

2 Pages V   1 2 >
Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

Collapse

> Similar Topics

  Topic Replies Topic Starter Views Last Action
No New Posts Post By Email To K2 Images Not Resizing
1 bossies 4,345 31st May 2019 - 10:49 AM
Last post by: Web Design Seo
No New Posts Post By Email Pro - Cron Warnings
JROUTER_MODE warnings
1 Brian Craigie 4,986 31st January 2019 - 08:42 AM
Last post by: Web Design Seo
No New Posts Post By Email, Error 500
500 error on backend
1 galamarco 4,396 17th January 2019 - 06:29 AM
Last post by: Web Design Seo
No new Pinned: Topic has attachmentsPost By Email Pro
Pro version of Post By Email component
113 Ivan Stamenov 99,319 17th January 2019 - 06:28 AM
Last post by: Web Design Seo
No new Post By Email Not Working Since Joomla 3.5.0 Update [solved]
5 tompuchner 21,520 2nd May 2016 - 07:04 AM
Last post by: Web Design Seo
No New Posts Post By Email Using Mms On A Mobile Phone
1 alexilio 13,389 13th April 2016 - 09:44 AM
Last post by: Web Design Seo
No New Posts Post By Email Jomsocial - Unable To Post To Wall
3 uglykidjoe 9,484 11th February 2016 - 07:25 AM
Last post by: Web Design Seo
No New Posts Post By Email Doesn't Works
1 cranky69 15,457 1st December 2015 - 10:30 AM
Last post by: Web Design Seo
No New Posts Post By Email Pro Won't Process Messages But Not Published
All messages are processed but some of them are not published
1 sconello 10,970 9th November 2015 - 11:53 AM
Last post by: Web Design Seo
No new Post By Email - "content Between Strings" Extraction Not Working
4 ritual_advert 11,476 4th November 2015 - 07:25 AM
Last post by: Web Design Seo


 



RSS Lo-Fi Version Time is now: 15th October 2019 - 03:35 AM
Clicky Web Analytics